iPhone, 4.2 beta에서 4.1로 downgrade, 1015에러 해결


1015에러는 다운그레이드 시 발 생하는 에러로..
애플은 다운그레이드를 지원하지 않는다고 한다.

http://support.apple.com/kb/TS1275?viewlocale=ko_KR

오류 1015: 이 오류는 iPhone, iPad 또는 iPod touch 소프트웨어를 다운그레이드하려고 할 때 발생합니다. 이전 .ipsw 파일을 사용하여 복원하려고 할 때 발생할 수도 있습니다. 이전 버전으로의 다운그레이드는 지원되지 않습니다. 이 문제를 해결하려면 Apple에서 제공하는 최신 iPhone, iPad 또는 iPod touch 소프트웨어로 복원해 보십시오.

개발용 iPhone에서 beta버전을 사용해 보고싶은 욕심에 설치했는데…
SDK 버전이 낮으면 iPhone에 못 올리는 문제가 발생한다.
( 생각해 보면 전에도 삽질 했었는데… 또한다.. ㅡ.ㅡ; )

그렇다고 SDK 까지 베타버전을 사용해서 개발할 수도 없는 일이고 해서
정식버전인 4.1로 다운그레이드를 시도해 봤다.
하지만 1015 에러가 발생한다.

iRecovery 관련 글들이 많으나 iOS 버전이 높아서 인지 잘 안되고…
iTunes는 1015 에러를 계속 내뱉는다.

1015를 애플에서 찾아보니 “이전 버전으로의 다운그레이드는 지원되지 않습니다.”
를 발견할 수 있다. 고로 베타버전 깔았으면 베타버전을 정식 4.2버전이 나올때 까지 쓰라는 얘기… ㅡ.ㅡ;
물론 경고 같은게 웹에 있을것 같다. 잘 보지 않고 설치한 사용자 탓도 없긴 하다만…
하여튼… 해결을 하기 위해서는 어둠의 방법을 사용하는 수밖에 없다.

구구절절하게 다시 떠들 필요없이 내가 참고 했던 싸이트를 링크한다.

* How to Restore iPhone 4, 3GS on iOS 4.0.1 Successfully, Bypassing iTunes 1004, 1015 Error
http://www.redmondpie.com/fix-itunes-1004-1015-error-and-restore-iphone-4-3gs-successfully-on-ios-4.0.1-how-to-guide/

* iPod, iPhone and iPad Firmware Download
http://www.felixbruns.de/iPod/firmware/

* TinyUmbrella – Unified TinyTSS and The Firmware Umbrella in ONE!
http://thefirmwareumbrella.blogspot.com/2010/05/tinyumbrella-unified-tinytss-and.html

– 끝 –

Advertisements

답글 남기기

아래 항목을 채우거나 오른쪽 아이콘 중 하나를 클릭하여 로그 인 하세요:

WordPress.com 로고

WordPress.com의 계정을 사용하여 댓글을 남깁니다. 로그아웃 / 변경 )

Twitter 사진

Twitter의 계정을 사용하여 댓글을 남깁니다. 로그아웃 / 변경 )

Facebook 사진

Facebook의 계정을 사용하여 댓글을 남깁니다. 로그아웃 / 변경 )

Google+ photo

Google+의 계정을 사용하여 댓글을 남깁니다. 로그아웃 / 변경 )

%s에 연결하는 중